Forum und email

Aspell (Obsolète)

Introduction

Les fonctions Aspell vous permettent de vérifier l'orthographe d'un mot, et d'offrir des suggestions de correction.

Note: Cette extension a été retirée de PHP et n'est plus disponible depuis PHP 4.3.0. Si vous voulez utiliser un outil de correction orthographique avec PHP, voyez plutôt pspell. Elle utilise la bibliothèque pspell et fonctionne avec les nouvelles versions de aspell.

Pré-requis

Aspell fonctionne avec de très vielles versions (jusqu'à la version .27.* ou presque) de la bibliothèque Aspell. Ce module et ces versions d'Aspell ne sont plus maintenues ou supportées. Si vous en avez besoin, la bibliothèque Aspell est disponible sur » http://aspell.sourceforge.net/.

Installation

En PHP 4, ces fonctions ne sont disponibles que si PHP a été compilé avec l'option --with-aspell[=DIR].

Voir aussi

Voir aussi pspell.

Table of Contents

  • aspell_check_raw — Vérifie un mot sans en changer la casse et sans essayer de supprimer les espaces aux extrémités [Obsolète]
  • aspell_check — Vérifie un mot [Obsolète]
  • aspell_new — Charge un nouveau dictionnaire [Obsolète]
  • aspell_suggest — Suggère l'orthographe d'un mot [Obsolète]